Announcement

Collapse
No announcement yet.

Total Brake Failure on my '03 R1150GS Adv. ... Who can help me?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Total Brake Failure on my '03 R1150GS Adv. ... Who can help me?

    I was riding to work this morning, and the "brake failure" light and the "!" light came on. I checked, and the brakes felt fine, so I assumed that it may be a false alarm due to a short, or something. I stopped at one light, and they felt sort of spongy, but I felt it was safe enough to continue to work. I went to stop at another light, and there was barely any brakes at all. ... I am now about to attempt to ride it home.

    My bike is my ONLY transportation!

    I do not have internet at my house, so to check email, and messages, I have to ride to a library.

    I have no cell signal where I live, - but can sometimes send and receive text's. If you care to try, my cell is (706) 662-9734.

    I have Wednesday the 9th of July off, but I am supposed to be back at work at 7 am on Thursday the 10th.

    "If" there is something I can check, or replace by myself, - I really can't afford to pay a shop to fix it.

    Somebody please help!

    Rodger W.
    Information@BMWMOAL.org

  • #2
    Sending a text Rodger...
    Current Bikes
    '16 BMW R1200GSA "Buck"
    '18 BMW G310GS "Tiny"

    Member;

    [I]BMWMOAL / BMWMOA / AMA / Dixie Dual Sport / IBA/ BMW Riders of Chattanooga

    I may not be here for a long time...but I am here for a good time!

    Comment


    • #3
      I hope you can get your brake problem solved quickly. Good luck.
      Tommy Z.
      2012 K1600GTL
      BMWMOA, BMWMOAL, AMA

      www.bayoubikers.net

      Comment


      • #4
        I took my bike into a local shop today hoping that flushing my brake fluid would fix my brake failure issue. They accidentally broke the bleeder valve off the back brake assembly, and the sevro-motors "scared" them, so they stopped with only topping off and bleeding the front brakes. ... I guess I am going to have to bring my bike up and drop it off at Moto Ace in Leeds to see what they think

        Comment


        • #5
          any update Rodger?
          Current Bikes
          '16 BMW R1200GSA "Buck"
          '18 BMW G310GS "Tiny"

          Member;

          [I]BMWMOAL / BMWMOA / AMA / Dixie Dual Sport / IBA/ BMW Riders of Chattanooga

          I may not be here for a long time...but I am here for a good time!

          Comment


          • #6
            I dropped it off at Moto Ace in Leeds yesterday afternoon. They were supposed to give her the "once over" today. I haven't heard anything back yet, so I plan to call them as soon as they open up again tomorrow. Meanwhile, my buddy John from Montevallo has loaned me his R1150R to ride until I can get my GS back.

            Comment


            • #7
              Roger,

              I just got back in town and saw the thread. If you can get the bike down to Enterprise this weekend, preferably early in the morning, I will do a complete ABS flush with you and see if we can solve the issue and prevent other idiots from taking a look-see! Did the first shop replace your bleeder valve that they broke?

              I do my own services and have done the ABS systems since 2001 with no issues, even the servo assisted. Jim and I just did my 04 RT a couple weekends ago.

              I have a few deadlines at work so I cannot travel, otherwise I would come up to you, knowing that transportation is an issue.

              Just let me know,

              Steve

              Comment


              • #8
                Thanks Steve, ... but at the moment, Moto Ace in Leeds still has my bike, and I am still on my friend John's R1150R. When I last spoke to the guys at Moto Ace, they said the hooked the computer to it, and there were several error codes that they cleared out. They rode it after that, and got an error code that is "unidentified". They say the servos all seem to be doing what they do, but the system is not developing the right pressure. They were closed today, and will be again tomorrow. I will call them on Tuesday, and see what they may have discovered since I last spoke with them.

                Comment


                • #9
                  No worries Roger. Just let us know what they say.

                  Steve

                  Comment


                  • #10
                    Roger,

                    Can you explain exactly what the lights were doing?

                    Comment


                    • #11
                      So what was the verdict Roger?

                      Comment


                      • #12
                        Took it to Moto Ace in Leeds, - they did a complete flush and bleed, cost was $130.00, and the problem is resolved!

                        Comment


                        • #13
                          That is great Roger!

                          Comment

                          Working...
                          X